No components marked as affected
Resolved
This incident has been resolved.
Monitoring
The fix had its intended effect, though it will take roughly another 40 minutes to process remaining jobs.
Monitoring
A fix has been implemented and we're monitoring the results.
Identified
The issue has been identified and a fix is being implemented.
Investigating
We are investigating reports of dataset trim operation being slow for some customers.