Resolved
A revert has happened, the query service is now operating normally.
The root cause has also been identified and we are actively working on it so queries are not affected again.
Investigating
Some queries are failing due to recent deployment, we are on it.