Resolved
All services have returned to normal operation. Queries are executing successfully, and internal traffic between services has been fully restored. We are continuing to monitor the system to ensure stability.
Identified
We've identified the root cause as a network configuration change that disrupted internal service-to-service communication. This caused query requests to fail, resulting in HTTP 500 errors.
Investigating
We are investigating reports of widespread query failures on the legacy EU instance. Users experiencing internal server errors when executing queries.