Resolved
Underlying infrastructure issues have been resolved, metrics queries on EU Edge Deployment should now be fully operational.
Monitoring
We have rolled out a fix and currently monitoring to ensure query performance is optimal.
Identified
We are experiencing some infrastructure issues on our EU Edge Deployment which may effect query performance for Metrics.