EU Monitor Processing failures
Resolved·Partial outage

We have identified and resolved issues with monitor processing in the EU region

Some of our EU customers could have experienced monitor processing issues.

During this period, gaps in alerting were a possibility due to instability issues caused by underlying scaling issues. Monitoring systems in other regions remained operational.

The issue was identified and resolved on Sunday evening, and all monitoring services in the EU region have since been fully restored.

To prevent similar issues in the future, we have added automated configuration validation, expanded deployment checks for regional dependencies, and introduced enhanced monitoring of our monitoring layer itself.

We apologise for the disruption this caused. The issue is now fully resolved, and monitoring and alerting in the EU region are operating normally.

Sun, Nov 2, 2025, 08:10 PM
(2 days ago)
·
Affected components
Updates

Resolved

We have identified and resolved issues with monitor processing in the EU region

Some of our EU customers could have experienced monitor processing issues.

During this period, gaps in alerting were a possibility due to instability issues caused by underlying scaling issues. Monitoring systems in other regions remained operational.

The issue was identified and resolved on Sunday evening, and all monitoring services in the EU region have since been fully restored.

To prevent similar issues in the future, we have added automated configuration validation, expanded deployment checks for regional dependencies, and introduced enhanced monitoring of our monitoring layer itself.

We apologise for the disruption this caused. The issue is now fully resolved, and monitoring and alerting in the EU region are operating normally.

Sun, Nov 2, 2025, 08:10 PM

Investigating

We are investigating failures to monitor processing in EU region

Sun, Nov 2, 2025, 08:00 PM(10 minutes earlier)