Ingest traffic surge
Resolved·Partial outage

Our system completed an emergency scale-out, we restarted all stuck pods, and confirmed backlog processing was back to nominal levels.

Wed, May 14, 2025, 09:57 PM
(1 month ago)
·
Affected components
Updates

Resolved

Our system completed an emergency scale-out, we restarted all stuck pods, and confirmed backlog processing was back to nominal levels.

Wed, May 14, 2025, 09:57 PM

Investigating

We experienced an unprecedented surge in incoming requests that saturated our ingest cluster.

Wed, May 14, 2025, 09:51 PM