<Major> Monitors continue misfiring
Resolved
Partial outage

We have monitored the systems since the fix to the query pipeline was deployed and not observed any signs of memory corruption since then. As noted previously, the problem was in our query infrastructure and the integrity of ingested data was never compromised.

Thu, Jan 9, 2025, 07:07 AM
1 week ago
Affected components
Updates

Resolved

We have monitored the systems since the fix to the query pipeline was deployed and not observed any signs of memory corruption since then. As noted previously, the problem was in our query infrastructure and the integrity of ingested data was never compromised.

Thu, Jan 9, 2025, 07:07 AM
21h earlier...

Monitoring

We've been observing the service closely over the past 24 hours and have deployed tooling to detect any more memory corruption. We've also released a fix for the query pipeline and will continue to monitor until confident the issue has been resolved.

Wed, Jan 8, 2025, 09:44 AM
22h earlier...

Monitoring

We have deployed a fix which should alleviate the excessive / misbehaving email notifications from Monitors. Monitors should not misfire again due to this issue. Rest assured the issue lies with our query infrastructure and therefore the integrity of ingested data is 100%.

Tue, Jan 7, 2025, 11:41 AM
51m earlier...

Monitoring

The issue has been resolved by restarting the processes which caused the malformed data to be returned. We're currently investigating the root cause which is likely originating from an external library corrupting shared memory.

Tue, Jan 7, 2025, 10:50 AM
2h earlier...

Monitoring

We've run mitigations and queries work correctly again, but we continue investigation for root cause.

Tue, Jan 7, 2025, 08:12 AM
52m earlier...

Investigating

We see another instance of monitors misfiring due to corrupted results of queries. The team is investigating the root cause of this recurring problem.

Tue, Jan 7, 2025, 07:20 AM